Hellfire103@lemmy.ca to Programmer Humor@lemmy.mlEnglish · 17 hours agoTIFU by not using objects in my object-oriented programming courseworklemmy.caimagemessage-square16fedilinkarrow-up153arrow-down18cross-posted to: programmer_humor@programming.dev
arrow-up145arrow-down1imageTIFU by not using objects in my object-oriented programming courseworklemmy.caHellfire103@lemmy.ca to Programmer Humor@lemmy.mlEnglish · 17 hours agomessage-square16fedilinkcross-posted to: programmer_humor@programming.dev
minus-squarevext01@lemmy.sdf.orglinkfedilinkarrow-up8arrow-down1·9 hours agoBalls.suck() is the correct syntax.
minus-squareRagingToad@feddit.nllinkfedilinkarrow-up4·9 hours agoDon’t you need to declare new Balls() first? Or do you suck() Balls static?
minus-squarexigoi@lemmy.sdf.orglinkfedilinkEnglisharrow-up8·edit-28 hours agoBallsFactory ballsFactory = new BallsFactory(); ballsFactory.setSuckable(true); Balls balls = ballsFatctory.create();
minus-squarewhats_all_this_then@lemmy.worldlinkfedilinkarrow-up4·edit-23 hours agoAll of this is okay, but it’s not production ready. This is what real production code looks like: SuckableFactory suckableFactory = new SuckableFactory(); Suckable balls = suckableFactory .setShape(SuckableShapes.round) .setCount(2) .create(); SuctionProvider mouth = SuctionProvider.getInstance(); SuckerFactory suckerFactory = new SuckerFactory(); Sucker sucker = SuckerFactory.create(): sucker.setSuctionProvider(mouth); sucker.setSuckable(balls); sucker.setIntensity(SuckerSuctionIntensities.medium); sucker.suckSuckable();
minus-squarewhats_all_this_then@lemmy.worldlinkfedilinkarrow-up6·3 hours agoPython port: from ballsucker import suck suck()
minus-squarevext01@lemmy.sdf.orglinkfedilinkarrow-up3·9 hours agoOr I didn’t using the correct naming convention!
Balls.suck() is the correct syntax.
Don’t you need to declare new Balls() first? Or do you suck() Balls static?
BallsFactory ballsFactory = new BallsFactory(); ballsFactory.setSuckable(true); Balls balls = ballsFatctory.create();
All of this is okay, but it’s not production ready. This is what real production code looks like:
SuckableFactory suckableFactory = new SuckableFactory(); Suckable balls = suckableFactory .setShape(SuckableShapes.round) .setCount(2) .create(); SuctionProvider mouth = SuctionProvider.getInstance(); SuckerFactory suckerFactory = new SuckerFactory(); Sucker sucker = SuckerFactory.create(): sucker.setSuctionProvider(mouth); sucker.setSuckable(balls); sucker.setIntensity(SuckerSuctionIntensities.medium); sucker.suckSuckable();
Python port:
from ballsucker import suck suck()
Or I didn’t using the correct naming convention!